
DH2323 Datorgrafik och interaktion (DGI), NA8740, Datorgrafik och användargränssnitt (DOA) 
Lab 1: Modeling and animation in Maya, lab designed by Gustav Taxén 

Lab 1: Modeling and animation in Maya 

Goals 
Testable goals (may be assessed through the exam): 
 

• Understand the fundamentals of polygon mesh modeling, including 
o creation of basic primitives 
o vertex editing 
o extrusion 
o principles of basic texture coordinate projection 

• Understand the fundamentals of key frame animation, including 
o motion curves and motion curve editing 
o the effect of continuous vs. discontinuous motion curve transitions 

• Understand the principle of three-point lighting 
 
Non-testable goals (positive side-effects from completing the assignment): 
 

• Gain experience in using a professional 3D modeling and animation tool 
• Use basic mesh editing tools creatively 
• Use basic animation tools creatively 

 
A  means that this is a step that you must do in order to complete the assignment. 

Resources 
 

• Learning movies, available within Maya under Help→Learning Movies. 
• Maya Getting Started Tutorials, available within Maya under Help→Tutorials: 

o Overview 
o Maya Basics 
o Polygonal Modeling 

 Introduction 
 Lesson 1: Modeling a polygonal mesh 

o Animation 
 Introduction 
 Lesson 1: Keyframes and the Graph Editor 

o Polygon Texturing 
 Introduction 
 Lesson 1: UV texture mapping 

o Rendering 
 Introduction 
 Lesson 1: Rendering a scene 
 Lesson 2: Shading surfaces 
 Lesson 3: Lights, shadows and cameras 
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A brief introduction to Maya 
The name Maya is a translation of the Sanskrit word which means illusion. The tool itself is built 
from a code base that has been collated from three products: Wavefront’s Advanced Visualizer, TDI’s 
Explore, and Alias’ Power Animator. Wavefront bought TDI in 1993, and Silicon Graphics bought both 
Alias and Wavefront in 1995. The combined company became Alias|Wavefront, and for a number of 
years it continued developing and publishing Alias Studio (as the new application became known). At the 
same time, the company was working on a new tool that combined a next-generation engine built from 
Alias Studio foundations and code from Wavefront. The result, which premiered in 1998, was Maya. At 
this time, Alias|Wavefront discontinued all their other product lines. In 2005 the company (which had 
been renamed Alias by that time) was acquired by Autodesk. 
 
One of the key features of Maya is its programmable, user-extendable tool set and graphical user interface. 
The original version of Maya had an unprecedented functionality and capability for modeling polygons, 
which gave it a distinct edge against the competition. It was also one of the first modeling tools that 
provided proper tools and interfaces for editing models in the perspective view. In 2003, Maya won an 
Academy Award “for scientific and technical achievement", citing use "on nearly every feature using 3-D 
computer-generated images.” Popular alternatives to Maya include 3DS Max, Softimage, Cinema4D, ZBrush, 
Form-Z, Houdini, LightWave, and Blender (which is OpenSource). 
 
Maya can be bewildering for beginners; it is an extremely powerful tool with a massive range of 
functionality, but this also means that its user interface is complex. Because the tool has a long history 
(and is built from a number of different code bases) some parts of the interface can feel inconsistent. But 
once learned, the Maya workflow is surprisingly efficient. If you plan to continue working with Maya, 
dedicating time to learn its interface properly is highly recommended. 

First steps 
The foundation of Maya’s rich functionality is a data flow network. Nodes in this network create, transform, 
or display geometry. When you use Maya’s tool set, you are really creating and/or connecting nodes in the 
network. When you manipulate an attribute of a Maya entity, you are really changing the parameters of 
one (or several) network nodes. The data network mechanism is extremely powerful, since it allows for 
creating new node types (using Maya’s built in scripting language, or Python), and it also allows for fine-
tuning objects that have been created, “after the fact”. Unfortunately, we will not have time to go into the 
details of the data network here but it is important to be aware of it, since the nodes-and-connections 
architecture is sometimes exposed in Maya’s user interface. 
 

 Begin by starting Maya. If you want to do the assignment on your own computer, you can 
download a student license of Maya from http://students.autodesk.com/. This assignment will 
assume that you are working with Maya Complete 2010, but the functions we will use are more 
or less equivalent to their counterparts in earlier versions (and trial versions). 

 If you have never used Maya before, watch the learning movies by selecting Help→Learning 
Movies. These movies show the basic tools that we will use in the assignment. 

 Read the tutorial texts that are listed under the Resources heading above. 
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A ball bouncing on a table 
The goal for this assignment is to create a simple table and a ball, and animate the ball so that it bounces 
onto (and off) the table. As you can see, the image does not have to be “pretty”. The goal of the 
assignment is to give you a feeling for how polygonal modeling and key frame animation works, which 
can be done in a few hours. Learning enough polygonal modeling and animation to be able to create 
complex, detailed, and believable models and animations, however, can take years! So if you are new to 
modeling and animation, don’t expect to be able to accomplish too much at this stage. 
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Components of polygon models 
In Maya, a polygon consists of a number of different components. The most important of these are vertices, 
edges, and faces: 
 

 
 
The most common Maya polygon workflow is to begin by creating a geometric primitive, such as a cube or a 
sphere. Then, its vertices, edges and faces are moved, rotated, and scaled, and new vertices, edges and 
faces are added, to achieve the desired shape. In order to do this, we need to be able to select and 
manipulate polygon components. At the same time, we often need to manipulate the entire object at once 
(we may need to move it, for example). We may also want to group together different objects into 
collections that can be transformed as one entity. 
 
Therefore, Maya distinguishes between these three different “levels” of geometry: 
 

1. Hierarchy – groups of objects. 
2. Object – a collection of polygons. Geometric primitives such as cubes or spheres are objects. 
3. Component – individual polygon components such as vertices, edges and faces. 

 
When we manipulate geometry, we obviously need to be aware of at which level we are working! This also 
has consequences for selection. Under the main menu, there are three buttons: 
 

 
 

The left button is called the Select by hierarchy button. When it is pressed, you select and manipulate 
hierarchies (groups of objects). The middle button is called the Select by object type button. When it is 
pressed, you select and manipulate objects. The right button is called the Select by component type button. 
When this is pressed, you select and manipulate polygon components. 
 

 Press the Select by components type button. 
 
To the right of the selection buttons, these buttons will appear: 
 

 
 
These buttons allow you to choose which components to select and manipulate. 

Vertex 

Edge 

Face 
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These are the buttons for selecting and manipulating vertices (points), edges (lines), and faces, 
respectively: 
 

   
 
It is important to understand that if you, for example, want to select and manipulate edges, both the select 
components button and the select edges button need to be pressed. It is perfectly fine to keep all component selection 
buttons pressed, but that also means that it can be difficult to get Maya to select, say, a vertex rather than 
an edge. It also means that it is easy to unintentionally select more than one different type of component 
– some functions only operate on faces, for example, so if you have both a face and a vertex selected, 
such functions won’t be possible to execute. 

Manipulating components 
Let’s see how all this works in practice! 
 

 Select File→New Scene to create a new scene. 
 Maya’s window layout can be configured in many different ways, but we want to use a standard 

four-window layout. Press this button: 

 
to choose a four-window layout. 

 Select Create→Polygon primitives→Cube. Drag out a box in the top view. Drag up in the 
front view to give the box a height. Press Enter when done. 

 
You should now have a box similar to this: 
 

 
 
At the left-hand edge of the screen, you should see a column of tool icons. This icon is the Select Tool: 
 

 
 
As the name implies, it is used to select things. 
 

 Choose the Select Tool. 
 At the top of the screen, press the Select by component type button 
 Press the Select point components button to enable selection of vertices. Make sure the other 

component selection buttons are disabled. 
 In the perspective view, drag a selection box over the top left vertex. 
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The vertex should become highlighted in yellow, like this: 
 

 
 

 Try selecting different vertices! Note that all vertices inside the selection box will become 
highlighted. If you want to add/remove vertices to the current selection, hold shift while you 
drag. 

 Deselect all vertices by dragging out a selection box that contains no vertices. 
 Press the Select line components button to enable selection of edges. Disable the Select point components 

button and make sure that all the others are disabled too. 
 In the perspective view, drag a selection box over the top left edge. 

 
The edge should be highlighted in orange, like this: 
 

 
 

 Try selecting different edges until you get the hang of it. 
 Deselect all edges by dragging out an empty selection box. 
 Press the Select face components button. Disable the others. 
 Click anywhere in the perspective view to activate it. 
 Press the 6 key on your keyboard to enable flat shading of polygons. 
 Select the top face of the box. 

 
The face should be highlighted in stippled orange, like this: 
 

 
 

 Try selecting different faces. Note that you may have to move the camera to see the back side of 
the box! If don’t know how to move the camera, you probably didn’t watch the learning movies, 
so do that now! 

 Press the 4 key on your keyboard to enable wireframe display of polygons. 
 Deselect everything. 
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Let’s try manipulating the box shape! In order to move stuff, you use the Move Tool: 
 

 
 

 Use the Select Tool to select a vertex. 
 Select the Move tool. 

 
You will see something similar to this: 
 

 
 
The arrows and the yellow box are manipulators. If you drag the yellow box, you can move the vertex. If 
you drag one of the arrows, you will constrain the motion to be along that axis. 
 

 Move the vertex until you get something similar to this: 
 

 
 
If you select more than one vertex, you can move them all together: 
 

 Select the two top right vertices: 
 

 
 

 Select the Move Tool and drag the vertices until you get something similar to this: 
 

 
 

 Now experiment with moving some edges and faces! 
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Let’s introduce a second object! 
 

 Select Create→Polygon primitives→Cube. 
 Drag out a new box using the top and front views. Press Enter when done. 

 
We will get another cube, like this: 
 

 
 

 Press the Select by object type button to enable selection of objects. 
 Select the new box that you just created. 
 Press the Move Tool button. Move the new box away from the old so you get something similar to 

this: 
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Let’s try to rotate the new box! To rotate objects, you use the Rotate Tool: 
 

 
 

 Select the Rotate Tool. 
 
You will see something similar to this: 
 

 
 
The circles are rotation manipulators. The yellow circle rotates in the camera plane. The other three circles 
rotate along the x, y, and z axis, respectively. 
 

 Use the rotation manipulators to rotate the box. 
 
You should get something similar to this: 
 

 
 
Let’s create a third object! 
 

 Select Create→Polygon primitives→Cube. 
 Drag out a new box using the top and front views. Press Enter when done. 
 Move the new box to the right so you get something similar to this: 
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Let’s scale the new box! To scale objects, you use the Scale Tool: 
 

 
 

 Select the newest cube object. 
 Select the Scale Tool. 

 
You will see something similar to this: 
 

 
 
These are scale manipulators. Dragging the yellow box in the middle will scale the object equally along all 
three axes. Dragging one of the other boxes will scale along the x, y, and z axis, respectively. 
 

 Use the scaling manipulators to scale the box. 
 
We now have a small scene that consists of three objects: 
 

 
 

We will now group together the two leftmost objects so we can manipulate them as a single entity. 
 

 Use the Select Tool to select the two leftmost objects: 
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 Choose Edit→Group. The two objects will become highlighted in green. 
 Press the Select by hierarchy button. 
 Select the Move Tool. 
 Move the two objects until you get something similar to this: 

 

 
 
Note that even though the two objects are grouped together, we can still manipulate the individual objects 
that make up the group: 
 

 Press the Select by object type button to enable selection of objects. 
 Select one of the two objects in the group: 

 

 
 

 Select the Move Tool and move the object: 
 

 
 

 Press the Select by hierarchy button. 
 Select the group. 
 Select the Move Tool and move the group again: 
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Modeling a table 
Let’s put our knowledge to use to create a simple table! 
 

 Select File→New Scene. 
 
Since we want the table to be symmetric, it could be useful to design it against a grid. This is the Snap to 
grid button: 
 

 
 
When it is pressed, everything will snap to the grid that you see in the orthogonal views: 
 

 Press the Snap to grid button. 
 Select Create→Polygon primitives→Cube. 
 Drag out a table top: 

 

 
 
We will base the table legs on cube primitives, and we want their shape to look something like this: 
 

 
 
As you can see, we need more vertices than the four corners. There are two ways to accomplish this. One 
is to create a cube with four corners and extrude it to create more vertices. The other option is to create a 
cube with more than one division along its height. We will use the second option here. 
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 Select Create→Polygon primitives→Cube  . Note that you should select the  sma l l  box to the 
right of the word Cube. 

 This will bring up some options on the right: 
 

 
 

 Under Create Settings, set Height divisions to 5. 
 Drag out a table leg, similar to this: 
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The next step is to sculpt the table leg into the appropriate shape by scaling its vertices. 
 

 Press the Select by component type button. Make sure that the Select point components button is the only 
one enabled. 

 Select the four bottommost vertices in the table leg. The simplest way to do this is to drag over 
them in the front or side view. Make sure that all of them are selected by looking at the 
perspective view: 

 

 
 

 Select the Scale tool. Drag the yellow center manipulator box to push the vertices a bit closer 
together: 

 

 
 

 Continue working your way up the table leg, dragging vertices together or apart to create a shape 
you like. 

 
You should get something similar to this: 
 

 
 

 Save your work by choosing File→Save scene. 
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The next step is to duplicate the leg so we get four legs. 
 

 Press the Select by object type button. 
 Select the table leg. Make sure nothing else is selected. 
 Press Ctrl-C to copy the leg. 
 Press Ctrl-V to paste a new leg. 
 Select the Move tool. 
 Move the copy away to its new location: 

 

 
 

 Press Ctrl-V to paste a new leg and use the Move tool to move it to its correct location. 
 Create the fourth leg in the same way. 

 
You should now have four table legs! 
 

 
 
Let’s group the five objects together into a single hierarchy: 
 

 Make sure that the Select by object type button is still pressed. 
 Select the table top and the four legs. 
 Choose Edit→Group to group together the table objects. 
 Save your work by choosing File→Save scene. 
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It would be nice to give the table surface a wooden texture. On the course webpage, you will find a file 
called wood.jpg. Let’s map that onto the table surface! 
 
In order to do this, we need to let Maya know how we want the image to be “pasted” onto our objects. 
This is called choosing a texture projection. Maya contains an extensive suite of functions for creating different 
texture projections, but going into the details is beyond the scope of this assignment. So for the table top, 
we will choose a simple planar projection and we will use a cylindrical projection for the legs. Let’s begin 
with the table top. 
 

 Press the Select by component type button. 
 Enable Select face components and make sure all other component buttons are disabled. 
 Select the top table face: 

 

 
 
Since there are so many menus in Maya, they are split into a number of menu groups. The function we need 
is in the Polygons menu group. You choose a menu group in this list box at the top left corner of the Maya 
window: 
 

 
 

 Choose the Polygons menu group. 
 Choose Create UVs→Planar Mapping  . 

 
This will bring up a dialog with some options: 
 

 
 
We want to project the texture from above, along the y axis. 
 

 Select Project from: Y axis. 
 Press Project. 
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This will bring up another set of manipulators: 
 

 
 
These manipulators allow you to scale the projection, but since we haven’t created a textured material for 
the table yet, there is nothing to see. We will come back to these manipulators later, but we first need to 
create a material. 
 
Maya contains a very powerful (and complex) system for creating shaders, and going into the details is 
beyond the scope of this assignment. We will simply create a Phong-based material and assign a texture to 
it. 
 

 Position the mouse cursor over the top face of the table. 
 Press and hold the right mouse button. A pop-up menu will appear. 
 Choose Assign New Material→Phong. 

 
This will bring up a number of material-related options on the right: 
 

 
 

 Press the checkerboard button to the right of the Color slider. This will bring up a dialog box: 
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 Press the File button. This will bring up another set of options: 
 

 
 

 Press the button with the file folder icon to the right of the Image Name line. 
 Navigate to wood.jpg and select it. 
 If you haven’t done so already, activate the perspective window and press 6 on your keyboard to 

show shaded polygons. 
 
You should see something similar to this: 
 

 
 
Our table now has a nice texture, but the scale is all wrong. We need to bring those texture mapping 
manipulators back so we can change it. If you remember, we said earlier that the underlying engine of 
Maya is a nodes-and-connection network. The planar texture projection is a node in that network. When 
we select the node, the manipulators will come back. To display network nodes, we use the Channel Box. 
 

 Ensure that the top table face is still selected. 
 Select Display→UI elements→Channel Box/Layer Editor. 

 
A list like this will appear: 
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 Select polyPlanarProj1.  
 To show the texture projection manipulators, select the Show Manipulator Tool. 

 
 Drag the manipulators until you get a good scale for the wood texture: 

 

 
 

Let’s assign textures to the other sides of the table top! Since the table is symmetric, we can actually work 
with pairs of faces: 
 

 Select the front face of the table top: 
 

 
 

 Turn the table around and add the opposite face to the selection. If you press 4 to show the table 
in wireframe, you should now have two faces highlighted in orange: 

 

 
 

 Place the mouse cursor over one of the two selected faces, press and hold the right mouse 
button, and choose Assign Existing Material→phong1. This is the material we just created 
(we didn’t give it a name, that’s why it received the default name phong1). 
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 Ensure that the two faces are still selected, then choose Create UVs→Planar Mapping  . In 
the dialog that appears, select the appropriate axis for the projection, depending on which pair of 
faces you have selected. You can determine this by looking at the small coordinate system 
symbol in the bottom left corner of the perspective window. Here, for example, the appropriate 
axis to project along is the z axis: 

 

 
 

 Use the manipulators that appear to set an appropriate scale for the texture. You may have to 
zoom in to be able to choose the appropriate manipulation boxes. 

 Repeat this procedure for the other table top face pair. 
 
You should now have a textured table top (we won’t bother with the bottom face)! 
 

 
 
Let’s do the legs as well! Creating a planar mapping for all of them is perfectly possible, but also a bit 
time-consuming, so let’s try a different thing! Imagine that one of the legs is surrounded by a cylinder and 
that that cylinder has a texture image. Then imagine that the image is projected from all angles around the 
cylinder onto the table leg faces. This is called a cylindrical projection. 
 

 Press the Select by object type button. 
 Select all the table legs. Make sure nothing else is selected. 
 Choose Assign Existing Material→phong1 to assign this material to all the legs. 

 



DH2323 Datorgrafik och interaktion (DGI), NA8740, Datorgrafik och användargränssnitt (DOA) 
Lab 1: Modeling and animation in Maya, lab designed by Gustav Taxén 

If we assign a texture projection now, Maya will enclose all four legs inside the imaginary cylinder, which 
is not what we want: we need to do this for each leg in turn. 
 

 Select one of the legs. Make sure nothing else is selected. 
 Choose Create UVs→Cylindrical mapping. 
 Use the manipulators to scale the mapping appropriately. 
 Repeat the procedure for the rest of the legs. 
 Save your work by choosing File→Save scene. 

 
We can introduce a bit more detail on the table top by extruding its top face. This operation duplicates the 
vertices of a polygon and connects each vertex copy to the original vertex, which allows you to “pull 
away” the new vertices to create a box. 
 

 Select the top face of the table top. 
 Choose Edit Mesh→Extrude.  

 
A new set of manipulators will appear: 
 

 
 
This set of manipulators combines the move, rotation, and scale manipulators into one tool. 
 

 Pull the arrow pointing upwards, out of the table (it is blue in the image above). 
 
This will drag out a new box: 
 

 
 

 Make the new face sit one grid square above the original table face: 
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 Select the four top vertices: 
 

 
 

 Disable snap-to-grid and use the scale and move tools to create a nice, beveled table top: 
 

 
 
As you can see in the picture above, the lighting seems to be smoothed over our bevel – we want the 
shading to be flat. As you probably know, lighting is in part defined by the normals at vertices. Maya 
actually separates between face normals and vertex normals. In this case, the vertex normals have been 
smoothed by the extrusion process. 
 

 Select the five top faces of the table: 
 

 
 

 Choose Normals→Set to face to set the vertex normals to be equivalent to the face normals. 
 Save your work by choosing File→Save scene. 

  
The table is now complete! Congratulations, you have just created your first textured 3D model! 
 

 
 



DH2323 Datorgrafik och interaktion (DGI), NA8740, Datorgrafik och användargränssnitt (DOA) 
Lab 1: Modeling and animation in Maya, lab designed by Gustav Taxén 

Modeling a ball 
Let’s create a ball! 
 

 Choose Create→Polygon primitives→Sphere. 
 Drag out a sphere, and press Enter when done. 
 Position the sphere above the table surface: 

 

 
 
A grey ball seems a bit boring, so let’s create a new material for it. 
 

 Select the ball object. 
 Put the mouse cursor over the ball, press and hold the right mouse button and choose Assign 

New Material→Phong. 
 In the list of options that appears, click in the grey color box to the right of the word Color. This 

will open a color selection dialog. 
 Choose an appropriate, bright, color and press Accept. 

 
You should now have a colored ball. Unfortunately, it is flat shaded since the vertex normals are set to be 
equivalent to the face normals. 
 

 Select the ball object. 
 Choose Normals→Average nornals. 

 
This should give you something similar to this: 
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Animating the ball 
When animating the ball, it is easiest to work in the front view. 
 

 Use the top view to position the ball in the middle of the table. 
 Click anywhere in the front view and press the space bar to cause the front view to cover all the 

other views. 
 Press 6 on your keyboard to enable shading of the polygons. 

 

 
 
When working with animation, we need functions that are available in the Animation menu group: 
 

 Choose the Animation menu group in the list box at the top left corner of the window: 
 

 
 
The idea is to let the ball appear somewhere above the table; bounce on it twice, and then drop off: 
 

 
 
Let’s begin by thinking about the timing of or animation. The number of frames we need is different 
depending on the kind of ball we have (heavy or light) and whether we want to display the motion in 
slow-mo or not, but let’s assume that we want the entire animation to take 2.5 seconds. At 24 frames per 
second, this amounts to 60 frames.  
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In Maya, you work with frames in the Time Slider, which is at the bottom of the screen: 
 

 
 

 If the Time Slider is not visible, turn it on by choosing Display→UI Elements→Time Slider. 
 
The top part of the time slider shows the playback range (the first frame should be highlighted). This is the 
part of the animation that Maya currently will play. The bottom part allows you to configure the total 
number of frames in the animation, as well as specifying the start and end frames of the playback range. 
In the example above, the animation starts at frame 1 and ends at frame 48. The playback range is from 
frame 1 to frame 24. 
 
We want the animation to go from frame 1 to frame 60, so 
 

 Enter 60 as the end time of the animation: 
 

 
 

 We also want the playback range to cover all frames, so enter 60 as the end of the playback 
range: 

 

 
 
We can now begin to outline where the ball should be at different frames, i.e., work out the extremes of the 
animation. At frame 1, we want the ball to be to the left, somewhere above the table. 
 

 Make sure that frame 1 is highlighted in the Time Slider. 
 Select the ball and move it its start position above the table: 

 

 
 

 Choose Animate→Set key. This will remember the current transformation of the ball and 
associate it with frame 1. 
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At the end of the animation, the ball should be to the right, below the table. 
 

 Click on frame 60 in the Time Slider. 
 Move the ball to its end position below and to the right of the table. 
 Choose Animate→Set key. This will remember the current transformation of the ball and 

associate it with frame 60. 
 

 
 

 Press the play button in the Time Slider. As the time advances, the ball should move from its 
start position to its end position. 

 Press the stop button in the Time Slider to stop playback. 
 
We want the two bounces to be at approximately 1/3 into the animation and 2/3, respectively, which 
corresponds to frames 20 and 40. 
 

 Click on frame 20 in the Time Slider. 
 Move the ball to its first bounce position on the table, about one third from the left edge of the 

table surface. 
 Choose Animate→Set key. 

 

 
 

 Click on frame 40 in the Time Slider. 
 Move the ball to its first bounce position on the table, about one third from the right edge of the 

table surface. 
 Choose Animate→Set key. 
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We now need to add extremes for the top “arcs” where the ball changes from an upwards movement to a 
downward movement. Since these will be in-between the bounces, they will happen on frames 30 and 50, 
respectively. 
 

 Click on frame 30 in the Time Slider. 
 Move the ball straight upwards to its first top “arc” position above the table. 
 Choose Animate→Set key. 

 

 
 

 Click on frame 50 in the Time Slider. 
 Move the ball straight upwards to its second top “arc” position above the table. 
 Choose Animate→Set key. 

 

 
 

The frames we have defined now are the basic, rough extremes for the animation. If you play it back now, 
you can see that it is a very rough animation indeed, but that it sort of suggests an outline of a ball 
bounce! 
 
Since there is nothing (apart from a negligible amount of drag) to lower the ball’s speed along the table, 
the speed in this direction should be constant. Depending on how you moved the ball, this may or may 
not be true. To get it right, we could click on the different extreme frames in the Time Slider and try to 
move the ball, but this is time-consuming, error-prone and relatively pointless. There is a better way – to 
edit the motion curves of the ball! This is done in an editor window called the Graph Editor. 
 

 Select the ball. 
 Display the Graph Editor by choosing Window→Animation Editors→Graph Editor. 

 
You should see something like this: 
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The Graph Editor shows all the properties of the ball that are being animated. The frames are along the x 
axis, and the parameter value is along the y axis. 
 

 In the Graph Editor, click on Translate X. 
 In the Graph Editor menu, choose View→Frame All to display the entire curve. 

 
The Graph Editor now displays the x position of the ball as a function of time: 
 

 
 
At frame 1, the x position of the ball is slightly less than -5, at frame 30 it is approximately 0, and at frame 
60 it is a bit larger than 10. This means that as time moves on, the x position of the ball will increase and it 
will move to the right. The black points are the extreme frames that we added before. 
 
But look at the curve! Since it is not straight, the speed of the ball will not be constant. To fix this, we need to 
make sure that the curve is a straight line from frame 1 to frame 60. 
 

 Choose the Select Tool (in the main Maya window). 
 Drag a selection box around the start point of the curve in the Graph Editor. 

 
This will display the tangents of the curve at frame 1, the first extreme frame: 
 

 
 
As you can see, the tangent has two dots. These can be moved to change the shape of the motion curve. 
We will not do this now, but instead note that if we want a straight line, we only need two points – the 
start and the end point. For the ball’s motion along the table, we don’t need more information than this. 
Hence, we can remove all the extreme frames for the x translation (except for the start and end points, obviously). 
 

 Make sure that Translate X is selected in the Graph Editor. 
 Choose the Select Tool (in the main Maya window). 
 Select all extreme frames in the Graph Editor except the start and end frames: 
 Choose Edit→Delete in the Graph Editor menu. 

 
The result should be a straight line from the start position to the end position: 
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If you play back the animation now, you will see that the x-axis motion of the ball is constant. To refine 
the overall motion further, let’s see if we can get the y-axis motion to become a bit better. 
 

 In the Graph Editor, select both Translate X and Translate Y. 
 Select View→Frame All in the Graph Editor menu. 

 
We can now see the y-axis motion too: 
 

 
 
If we think about the ball’s motion as two separate components (x translation and y translation), the y axis 
motion should be like a stationary ball bouncing up and down. In the image above, however, the curve is 
smooth: it begins with a downwards-facing velocity, and then proceeds in a wave-like motion throughout 
the rest of the animation. The first thing we should do is to make sure that the ball changes direction 
immediately as it strikes the table. At the moment, the curve tangents at these frames are horizontal – we 
want an abrupt, discontinuous change. To achieve this, we need to split the tangents at these frames and 
work separately with the left-hand and right-hand sides. 
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 Choose the Select Tool (in the main Maya window). 
 Select the y-motion extreme frame point at frame 20: 

 

 
 

 Choose Keys→Break tangents in the Curve Editor menu. This will allow us to change the left-
hand side of the tangent independently from the right-hand side. 

 Click on the point at the end of the left-hand side of the tangent. This will highlight the left half 
of the tangent. 

 Choose the Move Tool (in the main Maya window). 
 Drag the left-hand tangent point using the middle mouse button until the curve on the left is 

straight: 
 

 
 

 Left-click on the point on the right-hand side of the tangent. This will highlight the right half of 
the tangent. 

 Drag the right-hand tangent point using the middle mouse button until the curve on the left 
starts with a straight line: 

 

 
 
The ball will now change its direction in a discontinuous manner, which looks much more like a bounce. 
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 Break the tangent at the second table bounce and modify its tangent so the motion becomes 
discontinuous: 

 

 
 

 If the beginning of the animation looks strange, try changing the tangent at the first frame so that 
the ball accelerates slightly. 

 
The next step is to adjust the height of the bounces so that they feel right. 
 

 In the Curve Editor, select the point at the top of the arc at frame 30. 
 Choose the Move Tool (in the main Maya window). 
 Hold the shift button to constrain motion to the coordinate axes. Then drag the curve point 

upwards using the middle mouse button to adjust the height of the bounce. 
 Adjust the top of the arc at frame 50 too. 

 
As you move the curve points and run the animation, you will notice that the quality of the motion 
changes and that you may have to modify the tangents again. 
 

 Continue to manipulate the different extreme frames and their tangents until you get a motion 
you are happy with.  

 
Don’t forget that you can move the extreme frames horizontally as well, effectively changing their frame 
number. Keep the on-table bounces fixed, though, otherwise you may end up changing everything and 
ruining your timing. 
 

 Save your work by choosing File→Save scene. 
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Lighting and rendering 
Now that we have an animation, let’s create a nice-looking film clip! We’ll begin by lighting the scene. 
Maya has a large number of different light types and lighting-related functions, but we’ll stick to the basics. 
 
When working with lighting and rendering, we need functions that are available in the Rendering menu 
group: 
 

 Choose the Rendering menu group in the list box at the top left corner of the window: 
 

 
 

Lighting is a complete science in itself and there is an immense number of different theories and 
guidelines available. We’ll work from the basic principle of three-point lighting here. The idea is to use a key 
light to illuminate the character or object in the scene. We will then add a secondary light (or fill light) to 
illuminate the other parts of the scene. The final light we will add is a back light that helps separate objects 
in the foreground from objects in the background. Here is how they can be arranged. The illustration 
shows a scene from above, with three spherical objects in the center. The camera is at the bottom of the 
illustration, looking up. 
 

  
 
Shadows are a vital part of lighting, since shadows help define objects and provide us with cues that help 
us see how objects are situated in relation to one another. Computing shadows, however, is time-
consuming, so in Maya, shadow computation is disabled by default. If a shadow is to appear, the light 
source must have shadows enabled, there must be at least one object with shadow casting enabled (in 
front of the light source), and at least one object that is configured to receive shadows. In our scene, we 
want the ball to cast shadows and the table to receive shadows. 
 
Let’s begin by creating a key light. 
 

 Choose Create→Lights→Spot light. 

Camera 

Key light Fill light 

Back light 
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This will create a new light source at origo: 
 

 
 
The cone is the light cone; any surface within this cone will be lit. 
 

 Move and rotate the light (using the Move tool and Rotate tool) so that it points towards the table: 
 

 
 
As you can see, the perspective view does not show the lighting from the spot light. The reason is that 
Maya’s default real-time renderer is written for efficiency, not accuracy, so its lighting has very little to do 
with what we get when we render the scene. 
 

 Move and orient the camera in the perspective view so you can see the table and the ball. 
 Choose Render→Render current frame to render the scene. 

 
You will probably get something similar to this: 
 

 
 
As you can see, the spot light is indeed illuminating the table and the ball, but the cone is too narrow. 
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To increase the spot light cone, do this: 
 

 Select the light. This will bring up the following options on the right: 
 

 
 

 Drag the Cone Angle slider (or enter a value) to make it large enough to encompass the entire 
table and the ball. 

 
The result should be similar to this: 
 

 
 
Let’s add the fill light! 
 

 Choose Create→Lights→Spot light. 
 Move and orient the new light source into the fill light position. 
 Increase its cone angle if necessary. 
 In the light source options on the right, reduce Intensity to 0.5. 
 Click in the perspective view to activate it. 
 Choose Render→Render current frame to render the scene. 

 
You should get something similar to this: 
 

 
 
Let’s add a back light too! 
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 Choose Create→Lights→Spot light. 
 Move and orient the new light source into the back light position. 
 Increase its cone angle if necessary. 
 In the light source options on the right, reduce Intensity to 0.3. 
 Click in the perspective view to activate it. 
 Choose Render→Render current frame to render the scene. 

 
The effect of the back light should be subtle but noticeable and it should give the ball a bit stronger 
definition. 
 

 
 
You may have noted that shadows are missing from the picture, so let’s fix that! 
 

 Select the three light sources. 
 In the options on the right, click on the Shadows heading to display the shadow options. 
 Check the Use Depth Map Shadows button: 

 

 
 
We have now enabled shadows for the light sources. By default, objects are set to cast and receive 
shadows. 
 

 Click in the perspective view to activate it. 
 Choose Render→Render current frame to render the scene: 

 

 
 

 Save your work by choosing File→Save scene. 
 
Now that we have lights and shadows let’s render the animation! 



DH2323 Datorgrafik och interaktion (DGI), NA8740, Datorgrafik och användargränssnitt (DOA) 
Lab 1: Modeling and animation in Maya, lab designed by Gustav Taxén 

 
 Enable the perspective view by clicking in it. 
 Start the animation playback in the Time Slider. 
 Move the camera in the perspective view so you get a good view of the action. 
 Choose Window→Rendering Editors→Render Settings to open the Render Settings window. 
 Under File Output, choose AVI as the Image format. 
 Under Frame Range, enter 1 as Start frame and 60 as End frame. 
 Under Renderable Cameras, ensure that persp is the selected camera. 
 Under Image Size, choose an appropriate image size. 640x480 is usually a good place to start. 
 Click Close. 
 Choose Render→Batch Render to render the animation. 

 
The AVI file will end up in your My Documents\maya\projects\default\images folder; it 
will have the same file name as the name you chose for your scene. 
 

 Open the AVI file in Windows Media Player and enable looping to see that everything worked as 
intended. 

 When you are happy, save the Maya scene choosing File→Save scene. 
 

Submitting your work 
 

 Submit your AVI file to complete the assignment to lassekj@csc.kth.se, make sure to compress 
the file before submitting though. 


